Should package names be singular or plural?

For example, a type should be named TaskCollection instead of TasksCollection, as it is a collection containing instances of a Task.

A package named com.myproject.task does not mean that each contained class is an instance of a task. There might be a TaskHandler, a TaskFactory, etc.

A package named com.myproject.tasks, however, would contain different types that are all tasks: TakeOutGarbageTask, DoTheDishesTask, etc.

https://softwareengineering.stackexchange.com/questions/75919/should-package-names-be-singular-or-plural